New update: Version 0.9.10.2

Timo News 35 Comments

Today I released a new update to version 0.9.10.2. In the main, this version brings a better error handling and a debug mode. This can come in handy when it comes to errors with your connection to the Amazon webservice. When the connection to the webservice results in an error, it will be shown on the plugin’s setup panel. A list of common errors can be found here: http://www.wp-amazon-plugin.com/faq/#setup_errors
The debug mode can be activated on the setup panel by clicking the option “Activate debugging”. The debugging information will be shown in the textbox below this option. Do not forget to deactivate debugging when you do not need it anymore.

After the update you will find the option “

Some minor bugfixes round up this update.

 

 

 

Share this Post

About the Author

Timo

I started working on Amazon Simple Admin back in 2007 because I could not find an Amazon plugin for Wordpress that met my requirements. After many years of experience and hard work, the complete new ASA 2 Pro was released in early 2016. Follow me on Twitter.

Comments 35

    1. Post
      Author
    1. Post
      Author
  1. ande

    hallo timo,
    currently I am using this plugin, it’s really cool, but I have a question..
    is there possibility to add amazon customer review to the post?

    1. Post
      Author
      Timo

      Hi Ande,
      customer reviews are not supported at the moment, but I already have this feature request on my list. Maybe it will come with one of the next updates.

  2. Max

    This is a great plugin. Just have a few suggestions.

    In AsaCore.php, there is a line says:

    <img src="plugin_dir; ?>/img/misc_add_small.gif” /> Add Amazon item (ASIN):

    “bloginfo(‘url’) should really be “bloginfo(‘wpurl’) because not everyone install wordpress in root directory.

    2nd suggestion is if you can make the collections form automatically select the collection that is last used by the add function? So people don’t have to make the collection’s selection every time when they are adding to the same collection.

    Thanks.

    1. Post
      Author
  3. Ralf

    Hello Timo,

    I updated the plugin a few minutes ago from version 0.9.10 to the newest version. The custom templates are deleted, only the “normal” templates are in the tpl-folder.

    No problem, it’s alle backuped but I didn’t expect to fix it … Anywhy, I hope the feedback will help to improve this great plugin.

    greets, Ralf

    1. Post
      Author
      Timo

      Hi Ralf,
      thanks for your feedback. What exactly do you mean with “normal” templates? Those in the built-in directory?

      (Kannst mir auch gerne eine Mail schreiben)

  4. Finn

    Hey Timo,

    I was wondering if you could integrate a placeholder option in case a particular piece of information (e.g. price, customer rating etc.) is not or not yet available on Amazon.

    Right now if a piece of information is unavailable, there is only blank space which can mess up with your design…

    Thanks in advance!

    Finn

    PS: Love your plugin!

    1. Post
      Author
      Timo

      Hi Finn,
      thanks for your feedback. I am planning to support conditions in the templates. So you could check if a value is empty and display something else instead.

  5. Finn

    By the way, I am unable to deactivate the debugging. Whenever I tick the box and update the options, the debugging is still ticked and activated afterwards. Might be a bug.

    1. Post
      Author
      Timo

      Hm, this is confusing. It works on my installations no matter which update button I click. I guess it should be an individual issue depending on your installation.

      Please deactivate it manually because it is not recommended to keep the debug mode activated over a long time. Check for the option_name “_asa_debug” in your wp_options database table and set it to 0.

    1. Post
      Author
    1. Post
      Author
    1. Post
      Author
  6. Finn

    Hey Timo,

    I guess I discovered a bug in your plugin.

    When there are more than 1000 customer reviews for an item, the plugin shows only 1 customer review. How can I fix this?

    Best,

    Finn

    1. Post
      Author
  7. Finn

    Cool, thanks!

    By the way, I found another one.

    I tried using {$AmazonPrice} instead of the {$AmazonPriceFormatted} placeholder, because I wanted my currency to be “€” instead of “EUR”. However, some of the items (the ones where there are only used offers and no new one) still display the EUR at the end instead of just showing the amount (how it should be).

    Is there a fix for this or is there any other way to display the amazon price with the € currency sign instead of EUR?

    Thanks in advance!

    PS: I just donated 5 € 😉

    1. Post
      Author
      Timo

      Hi Finn,
      thanks for the donation! 🙂

      I checked what happens if there is no Amazon price. The plugin automatically sets the lowest offer formatted price for the Amazon price so that this placeholder is not empty. Maybe this is inconsistent and I should rather use the NOT formatted lowest offer price or even no auto set price at all? I could fix this for the next version and provide you with a test version.

      1. Finn

        Yeah, I guess it would be better to use the non-formatted lowest offer price if there is no other price available.

        You don’t have to, but it would be cool if you could send me a test version 😉

  8. Finn

    By the way, I’ve got an idea for a new feature to be added.

    It would be cool to have the option to have a different tag for every template instead of having only one global tag.

    It could be implemented like this:

    [asa templatename tag=another-partner-id-21]XXXXXXXXX[/asa]

    1. Post
      Author
  9. Mikey

    Hello!
    please make a update for performance. The plugin is realy great but performance are bad and need heavy load time.

    1. Post
      Author
      Timo

      Hi Mikey,
      thanks for your feedback. Do you use the cache? I am working on a feature for asynchronous loading of the products so that it does not affect your page loading speed.

      1. Mikey

        Yes i use it and it works great but in detail this plugin need more time as all my other plugins. it works good but not perfect optimize to performance. Asynchronous loading is great.

        1. Post
          Author
  10. Mikey

    Another wish. Delete the collection complete (for performance and size) and insert a wdiget to show the top 10 of a category.

    1. Post
      Author
      Timo

      Hi Mikey, a widget for top 10 of a category is a good point. But what do you mean with delete collection? It is possible to delete collections in the admin menu. Or do you mean to deactivate the collection feature once it has been activated?

  11. Natan

    Nice plugin Timo…
    i’ve basic question if you don’t mind:

    I often notice that it showed “price:-” and “0 used & new available from”. is that mean the product isn’t available at that time? if it does, it would be great if the plugin can alert about products’ availability (on dashboard) so we won’t advertise an empty stuff 🙂

    great works
    thanks

    1. Post
      Author
      Timo

      Hi Natan,
      thanks for your feedback. I have something like this on my feature request list already. It’s a good idea and this will be possible in future versions.
      Thanks for using ASA!

Leave a Reply

Your email address will not be published. Required fields are marked *