Jonas

Forum Replies Created

  • In reply to: Cache Problem bei Api 5.0?

    October 30, 2019 at 20:34 #15526
    Jonas
    Participant

    Ich glaube wir reden aneinander vorbei 🙂

    Den Fehlertext den ich gepostet habe, erscheint nur wenn ich das Debug-Log aktiviere. Ich dachte das hilft zur Fehlersuche. Wenn das Debug-Log nicht aktiviert ist, habe ich nur das Cache Problem ohne Fehler. Es wird beim öffnen der Seite einfach bei einigen Produkten kein Preis angezeigt.

    In reply to: Cache Problem bei Api 5.0?

    October 30, 2019 at 20:26 #15524
    Jonas
    Participant

    Ja die habe ich aktiviert und dachte dann siehst du vielleicht einen genauen Fehler. Das Problem ist natĂĽrlich auch ohne Debug-Output da.

    In reply to: Cache Problem bei Api 5.0?

    October 30, 2019 at 20:19 #15522
    Jonas
    Participant

    Ja, ich habe schon überlegt auf ASA2 zu wechseln, aber aktuell möchte ich noch auf ASA1 bleiben.

    Ich nutze den Platzhalter {$AmazonPriceFormatted}

    Hier mal das Debug-Log beim Fehler:
    atal error: Uncaught Error: Call to undefined method Asa_Service_PaApi5::getRequest() in /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/lib/Asa/Service/Amazon/Debug.php:55 Stack trace: #0 /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/AsaCore.php(2974): Asa_Service_Amazon_Debug->itemLookup(‘B00HAN1NBU’, Array) #1 /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/AsaCore.php(2894): AmazonSimpleAdmin->getItemLookup(‘B00HAN1NBU’) #2 /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/AsaCore.php(2607): AmazonSimpleAdmin->_getItem(‘B00HAN1NBU’) #3 /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/AsaCore.php(3555): AmazonSimpleAdmin->parseTpl(‘B00HAN1NBU’, ‘Preis a…’, Array, ‘preis’) #4 /www/htdocs/xxxxx/xxxxx/wp-includes/shortcodes.php(325): AmazonSimpleAdmin->handleShortcodeAsa(Array, ‘B00HAN1NBU’, ‘asa’) #5 [internal function]: do_shortcode_tag(Array) #6 /www/htdocs/xxxxx/xxxxx/ in /www/htdocs/xxxxx/xxxxx/wp-content/plugins/amazonsimpleadmin/lib/Asa/Service/Amazon/Debug.php on line 55

    Wenn du weitere ASINs benötigst, schicke ich die gerne auch. Je nach Refresh ist es aber immer mal wieder ein anderes Produkt, es wechselt ständig durch.

    In reply to: Probleme nach Umstellung auf Amazon API 5

    October 30, 2019 at 18:37 #15516
    Jonas
    Participant

    Funktioniert, perfekt!!! Vielen vielen Dank.