Cronjobs & Repo

  • October 27, 2016 at 20:27 #14056
    SLPTALS1
    Member

    Say I want 10-12 products on one page, with reviews and pricing. Which means I have to have a refresh the timestamp every 24 hours per TOS guidelines of Amazon…

    Timo was saying I can use cronjobs to update products in the backend cpanel/ssh, without having a user refresh the page to refresh the timestamp, total reviews, is this correct?

    I tried to explain Timo the 24 hour timestamp refresh dilemma before, which basically means if you list the price, you have to set Repo or Cache to 22-24 hours by Amazon’s TOS guidelines…

    Timo provided me with a really cool website where it lists products with 5-7 products on one page, but I hope this user knows, you must provide a timestamp by Amazon’s TOS, or you could face termination with the Amazon Associates program.

    I’ve been fooling around with cronjob in my cpanel, but I can’t seem to get it to work…

    * * * * * wget -q -O – http://www.healthyfoods.biz/wp-content/plugins/amazon-simple-affiliate/scripts/script.sh Asa2_Module_Repo_Cron_Refresh –lifetime=150 –limit=50 >/dev/null 2>&1

    I opened up two tickets in past week, not sure if Timo is mad at me for asking for a refund the first time or he’s on vacation. I plan on keeping his plugin regardless if I can’t have 10-12 products on one page, it’s a great plugin with incredible features…

    October 27, 2016 at 20:39 #14057
    SLPTALS1
    Member

    In fact, all of the showcase sites on the homepage are in violation of TOS because they don’t have a timestamp, hope everyone knows that, hate to see your guys account terminated on Amazon, once it’s terminated, it’s permanent.

    http://www.bt-lautsprecher.de
    http://digitalkamera-testportal.com

    • This reply was modified 4 years, 12 months ago by SLPTALS1.
    October 27, 2016 at 21:20 #14059
    Timo
    Keymaster

    I am not mad at you at all 🙂 I just answered to the ticket you created today, so I think that is a pretty good respond time 😉

    Here is my answer from the ticket:

    I guess the problem in your cronjob configuration is the “wget” part. The “script.sh” should not be accessed via HTTP but via the bash/shell. So please try to replace “wget -q -O -” with just “bash”. Then the shell script should be executed as expected. As long as you are testing, I would suggest to remove the error suppression part “>/dev/null 2>&1”. If it still does not work or does not produce any output, please change the option “Cronjob event” in options “Advanced” tab to anything other than the default, like “plugins_loaded” event.

    I think you are right about the Amazon TOS, but that is under the responsibility of each user. You have all the options with ASA 2 to show the required information like timestamp, disclaimer and so on.

    I hope I could help you to get the cronjob running. If it still won’t do, please let me know. I am sure that we will get it to work, as it finally runs for every user I have helped with it so far.

    Kind regards,
    Timo

You must be logged in to reply to this topic.

Register  |  Lost your password?