ASA1 – Collection – 500er Fehler in Version 1.4.7

  • April 11, 2020 at 17:47 #15887
    Melanie
    Participant

    Hallo, ich teste gerade das ASA1 für mich aus. Und bin dabei auf folgende Frage & Problem gestoßen: die Collection Funktion wäre für mich interessant: ich nutze die Version 1.4.7. Wenn ich eine Collection einbinde erscheint ein 500er Fehler Internal Server Error. D.h. die Seite ist nicht mehr aufrufbar. Gibt es hier ein Problem in der Version 1.4.7?
    Danke & Viele Grüße, Melanie

    April 13, 2020 at 16:28 #15888
    Timo
    Keymaster

    Hallo Melanie,

    aktuell ist mir kein Problem bekannt. Kannst du mal den WordPress Debug Mode aktivieren (siehe http://bit.ly/asa2-wp-debug-mode) und schauen, welcher Fehler protokolliert wird?

    April 13, 2020 at 17:24 #15889
    Melanie
    Participant

    Hallo Timo,
    die Einzel-Links funktionieren wunderbar. Nur bei der Collection steigt alles aus:

    Ein Fehler vom Typ E_ERROR wurde in der Zeile 209 der Datei /XXX/wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Cache.php verursacht. Fehlermeldung: Uncaught AsaZend_Cache_Exception: Invalid id or tag ‘B07TZHN76Q,B073Q4JX8’ : must use only [a-zA-Z0-9_] in /XXX/wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Cache.php:209
    Stack trace:
    #0 /XXX/wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Cache/Core.php(673): AsaZend_Cache::throwException(‘Invalid id or t…’)
    #1 /XXX/wp-content/plugins/amazonsimpleadmin/lib/AsaZend/Cache/Core.php(326): AsaZend_Cache_Core::_validateIdOrTag(‘B07TZHN76Q,B073…’)
    #2 /XXX/wp-content/plugins/amazonsimpleadmin/lib/Asa/Prefetcher.php(108): AsaZend_Cache_Core->test(‘B07TZHN76Q,B073…’)
    #3 /XXX/wp-content/plugins/amazonsimpleadmin/lib/Asa/Prefetcher.php(155): Asa_Prefetcher->addCollectedAsin(‘B07TZHN76Q,B073…’)
    #4 [internal function]: Asa_Prefetcher->collectAsinsFromShortcodeAsaCollection(Array)

    Danke & Viele Grüße, Melanie

    April 14, 2020 at 21:36 #15901
    Timo
    Keymaster

    Hallo Melanie,

    danke für die Fehlermeldung. Das kann ich mit meinen Tests nicht nachstellen, aber ich habe eine zusätzliche Prüfung an dieser Stelle eingebaut und mit der neuen Version 1.4.8 veröffentlicht. Bitte versuche es mal damit.

You must be logged in to reply to this topic.

Register  |  Lost your password?
Topic Tags