API error: RequestThrottled

  • February 22, 2018 at 16:39 #14577
    plexxy
    Participant

    Hallo!

    Ich hätte wieder mal eine Frage… Ich habe in den Logs ständig und viele dieser “API error: RequestThrottled” Fehler …
    Ich habe schon in den Optionen unter “Fortgeschritten” die Option “Requestlimit Behandlung” aktiviert sowie die Option darunter mit den maximalen Requests 1-5 pro Sekunde ausprobiert … trotzdem bekomme ich nachwievor diese Fehler… an was kann das liegen und was bedeutet das dann eigentlich genau? … Bekommt der User dann keine Amazon Produkte angezeigt …?

    Habe schon hier und über google eine Lösung probiert zu finden aber so richtig wurde ich nicht schlau daraus …

    mfg Christian

    February 26, 2018 at 21:46 #14579
    Timo
    Keymaster

    Hallo Christian,

    die Meldung bedeutet, dass pro Sekunde über deinen Account mehr Anfragen an die Amazon API gesendet werden, als erlaubt. Das kann aktuell auftreten, wenn du auf einer Seite mehrere Produkte eingebettet hast, deren Cache-Lebenszeit zum selben Zeitpunkt abgelaufen ist und daher alle auf ein Mal aktualisiert werden. Das wäre z.B. der Fall wenn der Cache auf eine Stunde gestellt ist und erst nach zwei Stunden ein erneuter Seitenzugriff erfolgt. Dann kann es dazu kommen, das ein Produkt nicht angezeigt wird.

    Vermeiden lässt sich das mit Einsatz des serverseitigen Cronjobs (http://docs.getasa2.com/cronjobs_repo_refresh.html), der die Produktdaten selbstständig aktualisiert, also ohne Beteiligung eines Benutzers. Dann sind die Daten immer aktuell und beim Anzeigen einer Seite muss nie die API bemüht werden.

    Ich hoffe, die Info hilft dir weiter.

    March 1, 2018 at 14:36 #14580
    plexxy
    Participant

    Hallo Timo!

    Danke für deine ausführliche Antwort … Habe bei meinem Hoster nun so einen Cronjob anlegen lassen mit folgenden Kommando:

    0 * * * * /[wp_path]/wp-content/plugins/amazon-simple-affiliate/scripts/script.sh Asa2_Module_Repo_Cron_Refresh –lifetime=86400 –limit=50

    der [wp-path] wurde angepasst …

    24 Stunden später tauchen im Log nachwievor diese Errors auf… Habe jetzt mal unter den Pluginoptionen -> Cache,
    alle verfügbaren Cacheoption auf 86400 Sekunden gesetzt … Mal morgen schauen wie es dann aussieht …

    viele Grüsse,
    Christian

    March 1, 2018 at 23:43 #14581
    Timo
    Keymaster

    Hallo Christian,

    das hört sich gut an. Wenn der Cronjob jetzt bei dir läuft, aktiviere bitte noch die Option “Deactivate auto-refresh” (siehe http://docs.getasa2.com/options_repo.html#deactivate-auto-refresh). Damit verhinderst du, dass Produkte beim Öffnen einer Seite (von Besuchern) aktualisiert werden, wodurch es unter Umständen noch zum RequestThrottled Fehler kommen könnte.

    Halte mich bitte auf dem Laufenden, ob sich die Situation dadurch verbessert.

    Gruß,
    Timo

    March 2, 2018 at 16:22 #14582
    plexxy
    Participant

    Hallo Timo!

    vielen Dank für deine Hilfe! , – durch die Aktivierung der Optionen die du vorgeschlagen hast, sind ausser “API error: AWS.InvalidParameterValue” keine “Throttled” Errors mehr im Log … an die letzten Erroreinträge mache ich mich jetzt noch ran … Dankeschön und ein schönes Wochenende!

    mfg Christian

    • This reply was modified 5 months, 3 weeks ago by plexxy.

You must be logged in to reply to this topic.

Register  |  Lost your password?