Issue with using the Amazon Product Advertising API for Associates (“Request from blacklist_[xyz] is throttled”)

In the last few days I got several requests about a not working plugin status. The error message always is “Request from blacklist_[xyz] is throttled” where [xyz] is a individual ID.

I did a lot of research on the official Amazon associates/developer forums. Amazon tries to split the API users in associates and sellers. For both sides there is a separate API. AmazonSimpleAdmin uses the Associates API. If you have a valid Associates account there will be no problem, as this API will continue working after August 2012 as usual. But if your account is somehow connected with a sellers account then Amazon will block your access to the Associates API after August 2012 as sellers must use the MWS Product API (Marketplace Web Service).

What does this mean for me?

If you receive the blacklist error message, it indicates that you use the seller version of the API. Then you must react and contact Amazon to resolve this. If you are not a seller you should migrate to the Products Advertising API for Associates. Please log into your Amazon account and get in contact with Amazon. Or try contacting mws-level2-eu@amazon.com as one ASA user got a reply from there with this content:
“I’m glad to hear that you have completed your migration to the Products Advertising API for Associates. I have removed your ID from the blacklist, which should allow you to access the PA-API for Associates as normal again.” 

In a few words: Take care that your Amazon AWS account is authorized to use the Products Advertising API for Associates after the end of August 2012. This is the API version that AmazonSimpleAdmin always used and which will unaltered continue working for valid accounts. This is a problem of your Amazon account and not a plugin error. AmazonSimpleAdmin will not support the Seller API MWS Product API (Marketplace Web Service) in the near future.

To my knowledge the reason for the error message is, that your account is not yet
registered to continue using the PA-API (Product Advertizing API). You should have gotten a mail regarding this case with the subject: “Action required: Register to continue using PA-API for your seller account”

Here are some informative extracts from the Amazon forums:

There currently exist two very different versions of PA-API (Product Advertizing API): One for Associates and one for Sellers. The Associate version will continue to exist. The Seller version shuts down 8/31/2012 in favor of the MWS Products API. [...] Any Associates who are still using the seller version of PA-API need to move to the Associate version of PA-API as they will not qualify to register for MWS.

Because there are currently many users of the seller version of PA-API who we have not been able to identify as valid Amazon sellers, and we are concerned that they may not be aware that the API is shutting down, we are beginning to blacklist those users. We will only allow them to continue using the seller version of PA-API (until 8/31/2012) if they can log into a valid seller account and contact MWS, identifying themselves as valid Amazon sellers. If they are using the seller version of PA-API for invalid use cases, as in they do not have active Amazon seller accounts, they will not be reinstated. Our goal with the blacklisting process is to drive valid sellers to contact us, acknowledge that they are aware of the impending shutdown, and identify the seller accounts for which they are using the seller version of PA-API. All Amazon sellers must migrate to the MWS Products API before it is shut down on 8/31/2012.

An easy way to determine whether your account may be blacklisted, is to log into your AWS account. If you use the exact same email address and password to log into your Amazon seller account, and you have an active seller business, you are not likely to be shut down early, although you must move to the MWS Products API before 8/31/2012. If you have one set of credentials to log into AWS, and a different set to log into your Amazon seller account, you may be on the list of users that will be shut down prior to 8/31//2012.

The seller version of PA-API is shutting down on 8/31/2012. Valid Amazon sellers need to move to the MWS Products API before that date so their seller business usage is not interrupted.

Tha associate version of PA-API is not shutting down. Valid Amazon associates need to move to the associate version of PA-API before that date so their associate business usage is not interrupted.

It will work ONLY for Associates (which is version 2011-11-01) with registered keys as Associates using it on their web sites to refer traffic to amazon as it was originally intend .. as I understand things.

Those seeing the blacklisted are those who never followed up on the Amazon email/message stating we needed to contact Amazon.
“Subject: Action required: Register to continue using PA-API for your seller account”
Dated 5-8-2012

(extracs from https://sellercentral.amazon.com/forums/thread.jspa?threadID=3860&start=15&tstart=0)

This post is also available in: German

, , , , , ,

4 Responses to Issue with using the Amazon Product Advertising API for Associates (“Request from blacklist_[xyz] is throttled”)

  1. Stubenwagen Vergleich October 8, 2012 at 8:05 am #

    Very nice Plugin. We use it on our site and it is perfect!

    Thanks!!!

    • Timo October 9, 2012 at 6:59 am #

      Thanks for your feedback. It’s my pleasure.

  2. Ceit December 27, 2012 at 2:30 am #

    I tried to clear the cache My API is activate yet I am still not getting anything.

    • Timo December 27, 2012 at 10:53 am #

      Have you tried activating the debug mode? Please send me the debug feedback. Maybe it gives us a hint.

Add Comment Register



Leave a Reply